Jump to content

Go via tasks at the start of scenarios


Recommended Posts



I have a question about tasks in scenarios. I have tested a couple of scenarios on the new Chatham main line. One displays tasks immediately and the other does not in the HUD. 

I looked at the debug from the scenario that has a blank task list. The first steps in the scenario are:

1) Go to reversing point (go via).

2) change ends

3) drive into Dover

4) pick up passengers

If I open the debug service window and manually set the reversing task as completed then the Dover stop is shown as the next task. The HUD then updates correctly as I continue the scenario.

The scenario that works correctly starts with a passenger task and the HUD works fine. 


It seems that there is a problem with the first task being a "go via" and the HUD does not pick it up automatically. 



Link to comment
Share on other sites


I just tried the scenario again and still not working. However, it is my fault because the issue I reported is not exactly the one I am seeing. Apologies. 

The first task in the scenario is a "stop at" before a reverse. I have attached some screen grabs for more detail.

"stop no task" shows the stop point at "(S) DVP Reversing Point" with no associated task. Note I have the RE2 and F3 HUDs active at the same time. 

"stop shows in debug" shows that the task is recognised in debug.

"drive now tasks" shows that the stop task is recognised in the drive screen before loading train simulator.





  • Like 1
Link to comment
Share on other sites

Alright we may have found the cause of this issue. Currently, RW Enhancer 2 is not being able to read markers data added for scenario purposes. RW Enhancer 2 is currently just reading route base markers. 

So we need to add the support of this in RWE 2 engine and cooking system. 

This will be done in a few days 🙂 Thank you for your patience.

  • Like 1
Link to comment
Share on other sites

I ran another scenario with and had a similar problem with the task vanishing. 

RW2 noted four tasks in the drive menu (screen shot 1). However, the starting station showed the start and the next task as one task (screen shot 2). The game did not show the go via task (screen shot 3). Once I left the first station, the go-via task was left (screen shot 4). 

Screen shot 5 shows a discrepancy between the task (go-via) and the debug (which shows a StopAt, presumably at Norwood Yard). Once I passed Streatham, the task vanished from the task view and the debug menu remained the same (screen shot 6).  Finally, if I set task id 2 as successful, then it showed the end task of the scenario as the next task (screen shot 7).

Please do not take the feedback as bad. I would like to use the tool more and like the sounds  as well as the GUI. In fact, I want to replace the old GUI with the one offered by RW2. 








Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...