Jump to content

les bug de l'editeur de TS


Jeje76
 Share

Recommended Posts

bonsoir tout le mondes

 

suite a de nombreux problemes et pas des petit je tenais a avertir ceux qui auraient l'idée de cloner leurs lignes ne le faite surtout pas ! car après vous vous retrouver avec ça comme bug je suis degouter je doit reprendre une version de ma ligne très ancienne afin de remettre l'originale du coup 2 mois de boulot de perdu ! bon c'est pas grave ma ville de St Lo serat plus réaliste et puis c'est tout enfin sa decourage beaucoup de tout perdre absolument tout! NE CLONEZ PAS VOS LIGNES  @olivierlyon a eu egalement le meme soucis que moi perte d'aiguillages ,perte de voies + plantage bref la totale  :

 

20191110202937_1.jpg

20191110204518_1.jpg

20191110204755_1.jpg

Edited by Jeje76
  • Like 1
Link to comment
Share on other sites

Courage à toi et à tous les créateurs qui subissent ce genre de désagrément à cause de cet éditeur assez bancal ! Ne baissez pas les bras et persévérez ça vaut le coup 🙂 On apprends beaucoup de nos erreurs et quand on refait des choses on les refaits toujours de façon bien meilleure après avoir gagné de l'experience 😉 

Attends un peu malgré tout avant de jeter tes sauvegarde récente, peut être que quelqu'un aura une solution a ce souçis dans la communauté.

  • Like 2
Link to comment
Share on other sites

Bonjour

C'est quand même bizarre car souvent je fais des clones pour sauvegarde et je n'ai pas de soucis par contre j'ai quelques fois des modifications des paramétrés  sur l'affichage seul soucis décalage de Google

ici un exemple des clones de la ligne Marseille  Martigues Lyon qui est une ligne importante et je viens de contrôler les clones rien ne manque

Je travaille avec Window 7 et en 32 bits

clone.thumb.jpg.5e674f7bcbe2f0843f05b12f2f13c77c.jpg

Jean Pierre

 

Link to comment
Share on other sites

je comprend pas alors pourquoi es ce que j'ai ce genre de bug bon je vais reprendre sur un autre clone alors c'est bizarre effectivement je ne suis pas le seul a avoir ce genre de soucis en tout cas.

si tu dit que c'est pas le clonage mais un bug de TS.

 

es ce que ce n'est pas du faite que je bosse sur TS 64 bits ? je suis sous windows 10 64bits

Edited by Jeje76
Link to comment
Share on other sites

Je dis pas que c'est un bug de TS ni que c'est pas le clonage je dis c'est bizarre par rapport a ce que je fais

Je n'ai aucune solution par contre comme je te l'ai dit passe la ligne a un copain de temps en temps ça peut te sortir de la mouise

JP

Edited by jeanpierrem
Link to comment
Share on other sites

ok  , bon du coup je vais recuperer un clone que j'ai fait car j'ai fait comme toi j'en a fait plusieurs au cas où j'aurais eu ce soucis.

j'aurais dut passer la dernière version a quelqu'un bon tempis je vais recup un des clones que j'ai et puis le passer a quelqu'un comme tu dit 😉

Link to comment
Share on other sites

Alors j'y vais de ma plume aussi 🙂   pas sur jéjé que ce soit le clonage.  

sur ma ligne et sans que rien ne fasse état d'un dysfonctionnement, je décide de me déplacer sur la map pour aller bricoler dans un endroit où je n'étais pas retourné depuis des lustres. eh là hop, le jeu se met en rideau et un joli panneau au milieu de l'écran qui me dit : OUT OF MEMORY , baissez vos paramètres graphiques , bla bla bla bla .....

là je suis pris d'un vent de panique en me disant : mais qu'est ce que j'ai fait comme connerie encore ???

j'envoie un message aux plus brillants ici même en expliquant le topo et surtout avoir un avis qui puisse m'orienter dans le dépannage (on se croirait sur une locomotive ou un TGV tient 😄 )

comme j'ai passé ma ligne et là dessus @jeanpierrem a raison, les symptômes n'étaient pas les mêmes chez tout le monde.

bref grâce @alain_m et ses connaissances informatiques plus poussées qu'il n'en faudrait, il me fera un clonage de la ligne avec les réparations d'usage. sans ça, a cette heure ci je serais déjà en train de repenser toute la reconstruction. autant vous dire que ça fait froid dans le dos.

alors que s'est il passé ? mystère. un beug informatique pur et simple et comme le disait franck cet éditeur complètement bancal !!

donc j'ai bien compris ma douleur, copie, sauvegarde a outrance ! et pas de suppression de ces sauvegardes tant qu'on est pas sur !! 🙂 

 

  • Like 2
Link to comment
Share on other sites

Guest alain_m

C'est trop gentil Olivier,

même si je n'ai pas beaucoup dormi ce WE, je suis bien content que tu n'ais pas à refaire tes voies

sur cette région NORD, ton travail étant superbe et conséquent...

Pour ma part si je fais un clône c'est avec RWTOOLS, jamais avec avec TS.  J'avais très mal vécu le fait que le clône TS décalait de 100m la vision Googlemap.

Il y aune méthode de réparation de cette erreur pour ceux qui manipule les fichiers XML.  le "properties" dans ce cas..

En ce qui concerne le BUG d'Olivier, j'ai eu le même, en un peu moins grave.. Sa ligne était parfaitement fonctionnelle, il s'agit bien d'un BUG système TS.

Trouver la parade n'était pas facile, mais je pense avoir mis en évidence un problème lié à la mémoire Cache,  et le  système .

Il y a eu dernièrement une MAJ très rapide d TS2020,  serait ce la cause..... L'editeur, en revanche fonctionne correctement en 64 bit, je n'ai plus d'erreurs

de liens de signaux et PN, c'est plutôt en 32 que j'avais des blocages. le fichier  trackbin  est le responsable

des bugs, (fichier unique gérant l'ensemble voies-pn-signaux-tiv...) .

Je rejoins le point de vue de Franck, il est quand même bancal cet éditeur...dommage , parce que l'on peut faire du très beau travail.

Cordialement

Alain😉

Link to comment
Share on other sites

Guest alain_m

Ce que tu peux faire , c'est de copier le fichier trackbin de ta ligne non clônée dans cellle clônée.

Cela devrait fonctionner...il se trouve dans ton dossier ligne, dans le répertoire network, l'ancien se mettra en .bak

Bon courage

 

Link to comment
Share on other sites

c'est ce que j'ai fait j'ai tout récuperer mais bon j'ai perdu la sauvegarde la plus récente enfin je l'ai jeter car tout étais complètement bug. j'aurais dut attendre avent de jeter bon tempis je doit tout refaire la ville de St Lo bon après je fait juste la partie qui est vers la gare je m'amuserais pas a faire toute la ville ^^   et merci pour ces conseils 😉

Edited by Jeje76
Link to comment
Share on other sites

Guest alain_m

en effet, dommage,

mais bon, tu as quand même pas tout perdu..

Petit conseil, en fait, je fais simplement plusieurs copie de ma ligne directement par Windows,

elles sont sur des supports différents... et j'ai toujours une version N-1  et N-2

comme çà elle garde toujours son même numéro, qui est son identité déclarée pour les fichiers...

donc plus facile à réparer....

Bon courage

Alain 😉

 

Link to comment
Share on other sites

salut

par contre du coup bon ce topic serat dedier aux divers bug que on peut recontrer  sur l'éditeur et du coup je voulais en profiter pour vous demander si je suis le seul a avoir le bug des pont qui ne peuvent pas etre selectionés je parle des pont numérotés genre dans des asset anglais je crois  vous avez des pont numéroté comme ceci ,je vous previens juste que une fois posé il est impossible de l'enlever après donc prudence 😉

perso avent de sauvgarder je regarde si le pont est selectionable afin de l'enlever en au cas où j'aurais trouver un  plus beau 😉

a moin qu'il y a une solution autre que d'enlever l'asset pour virer ce genre d'objet non selectionable.

c'est dommage car ils y en a des beau mais je ne les mettrais pas sur ma ligne pas envie d'avoir de problemes suplémentaire j'ai eu ma dose avec le crash 😄

faite attention aussi a ça 😉

je vous montre les quelles ont ce probleme c'est ceux là qui sont numéroter :

789.jpg

  • Like 1
Link to comment
Share on other sites

Guest alain_m

Bonjour,

C'est en effet un  problème.

Sur la DTG SouthMed, c'est le cas chez moi de la gare d'Aix en Provence, de la rotonde de Marseille.

Une fois validée, elle ne peut être retirée que par l'accès à la dalle correspondante du fichier bin dans  le scenery de la ligne..

Pour s'entrainer à le faire, il suffit de créer une ligne avec un seul élément problématique,  L'édition du fichier bin est facile avec RWtools, et sans risque

puisque l'enregistrement gardera une version .bak.

Alain 😉

Link to comment
Share on other sites

Guest alain_m

 je n'y avais pas pensé pour ce type d'objet....

Mais chez moi cela ne fonctionne pas,

tu peux faire un test ( pas sur NPDC.... 😤)

avec la gare d'Aix en Provence

Merci 😉

 

 

Edited by alain_m
Link to comment
Share on other sites

Oui oui t inquiète 😉.  Mais demain. Pour l instant je suis à Montpellier avec un machin bleu à pois roses pour Roissy.. et je rentre demain après avoir fait l inverse d aujourd’hui. Je te dirai, mais j ai déjà fait ce genre de manœuvre. Faut repérer le point faible de l objet qui se sélectionne, c est pas toujours simple je reconnais 😊

  • Like 2
Link to comment
Share on other sites

Guest alain_m

Ah oui.....go,  Le machin bleu à pois roses...Je te fais coucou par la pensée, quand tu passes à côté de chez moi....

Bonne route..sans doute sous la pluie

Alain

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

image.png.d44516590e7bf6f38e291638d956adf5.png

Becoming a premium member is enjoying all the benefits of the site and its services in an unlimited way and without advertising! Unlimited downloads, special customization items, 10% permanent discount in the store... With the RW Central Premium Subscription you are supporting the development and maintenance of the website and help us to develop new services and products.

👉Show Me Premium Subscriptions👈

OR

Disable your ad blocker if you want to help RW Central for free

Ok